Hovatek Forum
[Please help] Cherry mobile Flare J2 V2.0 mtk6580 Deadboot - Printable Version

+- Hovatek Forum (https://www.hovatek.com/forum)
+-- Forum: MOBILE PHONES HELP SECTION (https://www.hovatek.com/forum/forum-75.html)
+--- Forum: Android (https://www.hovatek.com/forum/forum-76.html)
+--- Thread: [Please help] Cherry mobile Flare J2 V2.0 mtk6580 Deadboot (/thread-25417.html)

Pages: 1 2


Cherry mobile Flare J2 V2.0 mtk6580 Deadboot - kissrap1200 - 22-10-2018

Tried to flash compatible ROM ( stock ROM of my phone)using so flashtool latest version and now it didn't boot but can be detected via PC I know the preloader maybe the culprit if anyone can help me


RE: Cherry mobile Flare J2 V2.0 mtk6580 Deadboot - xerxes - 22-10-2018

(22-10-2018, 04:35 PM)kissrap1200 Wrote:  Tried to flash compatible ROM ( stock ROM of my phone)using so flashtool latest version and now it didn't boot but can be detected via PC I know the preloader maybe the culprit if anyone can help me

How did the phone go dead?
Did you take note of the phone's original build no?
Was flashing the phone successful or got interrupted with an error?


RE: Cherry mobile Flare J2 V2.0 mtk6580 Deadboot - kissrap1200 - 23-10-2018

(22-10-2018, 07:32 PM)innagee Wrote:  
(22-10-2018, 04:35 PM)kissrap1200 Wrote:  Tried to flash compatible ROM ( stock ROM of my phone)using so flashtool latest version and now it didn't boot but can be detected via PC I know the preloader maybe the culprit if anyone can help me

How did the phone go dead?
Did you take note of the phone's original build no?
Was flashing the phone successful or got interrupted with an error?
Yes it successful yet did not boot yes i flahsed it with the compatibke factory  stock firmware


RE: Cherry mobile Flare J2 V2.0 mtk6580 Deadboot - X3non - 23-10-2018

(23-10-2018, 01:33 AM)kissrap1200 Wrote:  Yes it successful yet did not boot yes i flahsed it with the compatibke factory  stock firmware

have you tried disconnecting / reconnecting the battery?
post the link of the firmware you flashed


RE: Cherry mobile Flare J2 V2.0 mtk6580 Deadboot - kissrap1200 - 30-11-2018

(23-10-2018, 10:14 AM)X3non Wrote:  
(23-10-2018, 01:33 AM)kissrap1200 Wrote:  Yes it successful yet did not boot yes i flahsed it with the compatibke factory  stock firmware

have you tried disconnecting / reconnecting the battery?
post the link of the firmware you flashed


yes many times followed the turtorials ihave no problems flashing with my other phones


RE: Cherry mobile Flare J2 V2.0 mtk6580 Deadboot - X3non - 30-11-2018

(30-11-2018, 03:08 PM)kissrap1200 Wrote:  yes many times followed the turtorials ihave no problems flashing with my other phones

If you've removed and reinserted the battery and it's still dead then it's likely you flashed the wrong ROM. You need to look for and try another ROM from a different source
Did you try the ROM at https://drive.google.com/uc?id=0B5E8t4eu_XDRdWllUk5Bbnlacjg&export=download ?


RE: Cherry mobile Flare J2 V2.0 mtk6580 Deadboot - EMMANUS - 01-12-2018

As Xenon has already stated,it is most likely you flashed a wrong rom, and because you cannot salvage the correct info of the old firmware, you have to proceed by trial and error.

Have you tried these firmwares??

http://www.mediafire.com/file/o8cpnmdt1smt8np/Cherry_Mobile_Flare_J2_MT6580_V2.34_6.0.zip

http://www.mediafire.com/file/jal5qwjptzbqgqy/Cherry_Mobile_Flare_J2_V3.0_MT6580_14112016_6.0.zip

http://www.mediafire.com/file/mq41hydxmwmcuwu/Cherry_Mobile_Flare_J2_MT6580_V3.1_161114_6.0.zip


RE: Cherry mobile Flare J2 V2.0 mtk6580 Deadboot - kissrap1200 - 01-12-2018

already tried those firmware but no luck


RE: Cherry mobile Flare J2 V2.0 mtk6580 Deadboot - EMMANUS - 01-12-2018

(01-12-2018, 02:20 AM)kissrap1200 Wrote:  already tried those firmware but no luck

All 3 flashed successfully with no improvement?
Did you try charging for sometime after each flash?


RE: Cherry mobile Flare J2 V2.0 mtk6580 Deadboot - kissrap1200 - 01-12-2018

(01-12-2018, 02:41 AM)EMMANUS Wrote:  
(01-12-2018, 02:20 AM)kissrap1200 Wrote:  already tried those firmware but no luck

All 3 flashed successfully with no improvement?
Did you try charging for sometime after each flash?

yes still no luckl im using v2 flare j2