Talk with a Hovatek Engineer/Developer. Start Now

Learn Mediatek Software Repairs Online! Enroll

Need feroA5002 Stock ROM v0010

Post: 1 by Taoleen

Phone:: Fero
A5002 Android 6.0, build/software number:

I flashed an older firmware(FSA5002v0002 gotten from to my phone using research download vR4.0001, because I wanted to replace the recovery.img in the .PAC file with TWRP ,to root my phone.
This method wasn't successful so, I had to flash stock recovery.

Everything in the firmware from works fine, except the camera("cannot connect to the camera"), and there's a red text at the top right corner of the screen that won't go away ("Not Efused Not Verified").

I've already given up on rooting this phone cos I've tried everything (flashing via fastboot, unpacking recovery.img, editing system.img with yaffey , unlocking bootloader e.t.c).
I can't even backup the phone with miracle box("bootload error id:1).

The only thing possible on this phone is to flash stock ROM through research download.

I just need the original firmware (FSA5002v0010) to fix the camera and "red text on screen" issues.

PLEASE Help!!!!
I will never buy a spreadtrum phone again.

find Reply

Post: 2 by Taoleen

This is the ROM I flashed

The recovery.img in this .PAC file cannot be unpacked or flashed through fastboot, but it works with research download. I don't know why.....

I tried to 'read' another phone that has the latest firmware(FSA5002v0010) with miracle box, but I got the same 'bootload error id:1' message. Maybe all Fero A5002 phones are not compatible with miracle box.

I don't know how to upload the screenshots here.
find Reply

Post: 3 by Taoleen

Camera error
find Reply

Post: 4 by Taoleen

Red text at top right corner of screen
find Reply

Post: 5 by X3non

(15-12-2017, 11:59 AM)Taoleen Wrote:  Phone:: Fero
A5002 Android 6.0, build/software number:
PLEASE Help!!!!
I will never buy a spreadtrum phone again.

this is a different rom build, you can try it and see the outcome; Fero_FSA5002_v0001_04012017 @

as for miracle box not working, you are probably using an old version. you'll most likely need a newer version of the software along with the hardware dongle.
is the file name of the recovery image in the pac file recovery-sign?
find Reply

Post: 6 by Taoleen

No, the filename is "recovery.img" but the .PAC file is "FSA5002v0002_2017-01-10_CTS_signed.pac"
find Reply

Post: 7 by Taoleen

Unpacking recovery.img error
find Reply

Post: 8 by Taoleen

Fastboot error
find Reply

Post: 9 by X3non

(15-12-2017, 02:26 PM)Taoleen Wrote:  No, the filename is "recovery.img" but the .PAC file is "FSA5002v0002_2017-01-10_CTS_signed.pac"

upload this recovery img lets have a look at it.
BTW have you tried the other rom build i posted?
find Reply

Post: 10 by hovatek

(15-12-2017, 02:36 PM)Taoleen Wrote:  Unpacking recovery.img error

I think you're dealing with signed images and a signed pac. That would explain why any form of modification fails.
Try unpacking the images using the guide at to verify my theory

We have a reply schedule for Free Support. Please upgrade to Private Support if you can't wait.
find Reply

Users browsing this thread: 1 Guest(s)

© 2023. Powered by Hovatek...just a button away! Software by MyBB.