Hovatek Forum MOBILE Android [Please help] Cant install rom on Moto e32s (xt2229-2)
Try our Online TWRP Builder..its free!
Can't login? Please, reset your password.


[Please help] Cant install rom on Moto e32s (xt2229-2)

[Please help] Cant install rom on Moto e32s (xt2229-2)

migania
migania
migania
Enthusiastic Member
11
13-06-2024, 07:01 PM
#1



Hello, im trying to install stock rom for moto e32s using SP Flash Tool but im getting status_sec_auth_file_needed error. I tried googling but i cant really find a solution. I can answer any question or provide more info about the issue if requested.
maxpayne
maxpayne
maxpayne
Intern
3,602
14-06-2024, 08:31 AM
#2
(13-06-2024, 07:01 PM)migania Hello, im trying to install stock rom for moto e32s using SP Flash Tool but im getting status_sec_auth_file_needed error. I tried googling but i cant really find a solution. I can answer any question or provide more info about the issue if requested.

Unless you have the scatter format firmware and auth file or disabled SLA/DAA, this won't work.
What is the condition of the phone? Can it enter fastboot? If it can, try https://www.hovatek.com/forum/thread-37327.html
This post was last modified: 14-06-2024, 08:32 AM by maxpayne.

Note!
We have a reply schedule for Free Support. Please upgrade to Private Support if you can't wait.
migania
migania
migania
Enthusiastic Member
11
14-06-2024, 09:06 AM
#3
(14-06-2024, 08:31 AM)maxpayne
(13-06-2024, 07:01 PM)migania Hello, im trying to install stock rom for moto e32s using SP Flash Tool but im getting status_sec_auth_file_needed error. I tried googling but i cant really find a solution. I can answer any question or provide more info about the issue if requested.

Unless you have the scatter format firmware and auth file or disabled SLA/DAA, this won't work.
What is the condition of the phone? Can it enter fastboot? If it can, try https://www.hovatek.com/forum/thread-37327.html

I got the firmware from the Rescue and Smart Assistant. The phone is in good condition, its not bricked, can enter Fastboot. I will try to follow the thread you posted, thank you. If anyone has any other ideas i will also appreciate them.
migania
migania
migania
Enthusiastic Member
11
15-06-2024, 07:58 AM
#4
(14-06-2024, 08:31 AM)maxpayne
(13-06-2024, 07:01 PM)migania Hello, im trying to install stock rom for moto e32s using SP Flash Tool but im getting status_sec_auth_file_needed error. I tried googling but i cant really find a solution. I can answer any question or provide more info about the issue if requested.

Unless you have the scatter format firmware and auth file or disabled SLA/DAA, this won't work.
What is the condition of the phone? Can it enter fastboot? If it can, try https://www.hovatek.com/forum/thread-37327.html

Hey, i managed to unlock it but now there is "Unknown Carrier" overlay thing, doesnt allow me to use the sim card, did i screw up? Is it fixable?
migania
migania
migania
Enthusiastic Member
11
15-06-2024, 02:21 PM
#5



I managed to install the firmware but now the phone shows "Unknown Carrier" overlay and the IMEI numbers are not there (checking in bootloader shows all 0s), any idea how to fix this? Is this phone done for? Will it be working if i try to set the IMEIs manually (i saved them before installing the firmware if that matters).
maxpayne
maxpayne
maxpayne
Intern
3,602
17-06-2024, 08:33 AM
#6
(15-06-2024, 02:21 PM)migania I managed to install the firmware but now the phone shows "Unknown Carrier" overlay and the IMEI numbers are not there (checking in bootloader shows all 0s), any idea how to fix this? Is this phone done for? Will it be working if i try to set the IMEIs manually (i saved them before installing the firmware if that matters).

Was the firmware you flashed same as the phone's original carrier?

Note!
We have a reply schedule for Free Support. Please upgrade to Private Support if you can't wait.
migania
migania
migania
Enthusiastic Member
11
17-06-2024, 05:56 PM
#7
(17-06-2024, 08:33 AM)maxpayne
(15-06-2024, 02:21 PM)migania I managed to install the firmware but now the phone shows "Unknown Carrier" overlay and the IMEI numbers are not there (checking in bootloader shows all 0s), any idea how to fix this? Is this phone done for? Will it be working if i try to set the IMEIs manually (i saved them before installing the firmware if that matters).

Was the firmware you flashed same as the phone's original carrier?
Same as the phones original carrier? Im not sure exactly what you mean. I flashed it with the official Motorola Resue and Smart Assistant which asks you for the exact model, which it was the same as i have.
maxpayne
maxpayne
maxpayne
Intern
3,602
19-06-2024, 09:05 AM
#8
(17-06-2024, 05:56 PM)migania Same as the phones original carrier? Im not sure exactly what you mean. I flashed it with the official Motorola Resue and Smart Assistant which asks you for the exact model, which it was the same as i have.

Your original issue was that you couldn't flash with SP flash tool but have been able to using Rescue and Smart Assistant. What remains the problem?

Note!
We have a reply schedule for Free Support. Please upgrade to Private Support if you can't wait.
migania
migania
migania
Enthusiastic Member
11
19-06-2024, 09:31 AM
#9
Tbhe
(19-06-2024, 09:05 AM)maxpayne
(17-06-2024, 05:56 PM)migania Same as the phones original carrier? Im not sure exactly what you mean. I flashed it with the official Motorola Resue and Smart Assistant which asks you for the exact model, which it was the same as i have.

Your original issue was that you couldn't flash with SP flash tool but have been able to using Rescue and Smart Assistant. What remains the problem?

The remaining problem is that it doesnt accept any sim card. When you put one in it asks you to enter SIM ME (NP) code. I assumed its something like a sim lock? The IMEI numbers are gone, showing all 0s which i assume is why i have that issue.
maxpayne
maxpayne
maxpayne
Intern
3,602
28-06-2024, 01:26 PM
#10
(19-06-2024, 09:31 AM)migania The remaining problem is that it doesnt accept any sim card. When you put one in it asks you to enter SIM ME (NP) code. I assumed its something like a sim lock? The IMEI numbers are gone, showing all 0s which i assume is why i have that issue.

On Motorola. It could be either corrupted nvram/nvdata or wrong firmware flashed.

Note!
We have a reply schedule for Free Support. Please upgrade to Private Support if you can't wait.
Users browsing this thread:
 1 Guest(s)
Users browsing this thread:
 1 Guest(s)
YtWhTl