Talk with a Hovatek Engineer/Developer. Start Now

Learn Mediatek Software Repairs Online! Enroll

Firestick 3rd gen

Post: 1 by steveceltis

Hi, is there a way to flash firestick 3rd gen (MT8695)? 
Thanks in advance

find Reply

Post: 2 by AutoResponder

Thank you for reaching out for support. Due to high demand, our free support services may experience some delays in response time. We apologize for any inconvenience this may cause.
Alternatively, we offer private support where you can receive dedicated attention and prompt support. These sessions are designed to provide personalized solutions to your specific needs.
If you are interested in scheduling a private session, please visit
find Reply

Post: 3 by maxpayne

(06-10-2023, 07:14 AM)steveceltis Wrote:  Hi, is there a way to flash firestick 3rd gen (MT8695)? 
Thanks in advance

Please provide more information e.g model and why you want to flash
find Reply

Post: 4 by steveceltis

I tried using SPFT but I don't have the scatter file. So I tried to create one but when I go to connect the Firestick it gives me DA error. I can't find a DA file suitable
I also tried with bypass_utility but the result is device download agent authorization: False
I would like to do a dump first and then flash an older version

Attached Files
find Reply

Post: 5 by steveceltis

This is the information (see attachment)

Attached Files
find Reply

Post: 6 by maxpayne

(06-10-2023, 04:12 PM)steveceltis Wrote:  This is the information (see attachment)

Attach screenshot of the SP flash tool error
You can also try WWR

Or MTK client
find Reply

Post: 7 by steveceltis

SPFT's error is this

Attached Files
.jpg error_SPFT.jpg Size: 16.16 KB  Downloads: 2
find Reply

Post: 8 by steveceltis

After starting to create the scatter file with WwR I get this error when I go to connect the Firestick.
Obviously it doesn't have any buttons I can press....

Attached Files
.jpg SPFT screenshot 1.jpg Size: 120.28 KB  Downloads: 1
.jpg SPFT screenshot 2.jpg Size: 88.76 KB  Downloads: 1
find Reply

Post: 9 by steveceltis

And with MTK client it gives me this back (I deleted the file MTK_AllInOne_DA_5.1824.bin)

.jpg error MTK client.jpg Size: 115.46 KB  Downloads: 3
find Reply

Post: 10 by steveceltis

I tried with MTK Bypass utility but it gives this error
.jpg MTK Bypass_error.jpg Size: 398.82 KB  Downloads: 3
find Reply

Users browsing this thread: 1 Guest(s)

© 2023. Powered by Hovatek...just a button away! Software by MyBB.