Hovatek Forum MOBILE Android [Tool] Acer B3-A40: SP Flash Tool stuck at 0%
Try our Online TWRP Builder..its free!
Can't login? Please, reset your password.


[Tool] Acer B3-A40: SP Flash Tool stuck at 0%

[Tool] Acer B3-A40: SP Flash Tool stuck at 0%

mdm
mdm
mdm
Newbie
1
12-03-2023, 11:15 PM
#1



Hi,

I am trying to re-flash Acer Iconia One 10 tablet. 
It is stuck at he boot logo, also no recovery menu showing up, except once: after some hours of showing the boot logo it suddenly displayed "Supported Api:3" at the otherwise black screen bottom. 

I am using SP Flash Tool 5.2208 with a scatter file, that I found in some forum thread, but it seems to be ok and is matching the addresses and parts found in scatter.txt file 
.txt
scatter.txt
Size: 415 bytes / Downloads: 11
of the OS firmware from 
https://global-download.acer.com/GDFiles...A70N_A.zip

A read back was successful using this scatter file, see
.txt
MT8167_Android_scatter.txt
Size: 9.72 KB / Downloads: 31


But any Download is stuck after the DA agent is loaded, see 
.png
Screenshot from 2023-03-12 22-49-58.png
Size: 130.28 KB / Downloads: 8


The console output is
---------------------------------------------------------------------------
USB port is obtained. path name(/dev/ttyACM0), port name(/dev/ttyACM0)
device path: /dev/ttyACM0

DA high speed USB port detected: /dev/ttyACM0
DA Connected
Check Storage Life Cycle: S_DONE(0)
executing DADownloadAll...
Stage:
[8] WRITE TO PARTITION [ lk ]

Download failed.
Disconnect!
User stopped.
------------------------------------------------------------------

What might be causing the download to fail? 
Any advice gladly appreciated.

Regards

mdm
Abdulakeem14
Abdulakeem14
Abdulakeem14
Senior Member
1,757
13-03-2023, 05:10 PM
#2
(12-03-2023, 11:15 PM)mdm Hi,

I am trying to re-flash Acer Iconia One 10 tablet. 
It is stuck at he boot logo, also no recovery menu showing up, except once: after some hours of showing the boot logo it suddenly displayed "Supported Api:3" at the otherwise black screen bottom. 

I am using SP Flash Tool 5.2208 with a scatter file, that I found in some forum thread, but it seems to be ok and is matching the addresses and parts found in scatter.txt file  of the OS firmware from 
https://global-download.acer.com/GDFiles...A70N_A.zip

A read back was successful using this scatter file, see

But any Download is stuck after the DA agent is loaded, see 

The console output is
---------------------------------------------------------------------------
USB port is obtained. path name(/dev/ttyACM0), port name(/dev/ttyACM0)
device path: /dev/ttyACM0

DA high speed USB port detected: /dev/ttyACM0
DA Connected
Check Storage Life Cycle: S_DONE(0)
executing DADownloadAll...
Stage:
[8] WRITE TO PARTITION [ lk ]

Download failed.
Disconnect!
User stopped.
------------------------------------------------------------------

What might be causing the download to fail? 
Any advice gladly appreciated.

Regards

mdm

Use format+download option in Sp flash tool
You can also try miracle box @ https://www.hovatek.com/forum/thread-14106.html
emmc might be damaged
maxpayne
maxpayne
maxpayne
Intern
3,064
16-03-2023, 10:18 AM
#3
(12-03-2023, 11:15 PM)mdm Hi,

I am trying to re-flash Acer Iconia One 10 tablet. 
It is stuck at he boot logo, also no recovery menu showing up, except once: after some hours of showing the boot logo it suddenly displayed "Supported Api:3" at the otherwise black screen bottom. 

I am using SP Flash Tool 5.2208 with a scatter file, that I found in some forum thread, but it seems to be ok and is matching the addresses and parts found in scatter.txt file  of the OS firmware from 
https://global-download.acer.com/GDFiles...A70N_A.zip

A read back was successful using this scatter file, see

But any Download is stuck after the DA agent is loaded, see 

The console output is
---------------------------------------------------------------------------
USB port is obtained. path name(/dev/ttyACM0), port name(/dev/ttyACM0)
device path: /dev/ttyACM0

DA high speed USB port detected: /dev/ttyACM0
DA Connected
Check Storage Life Cycle: S_DONE(0)
executing DADownloadAll...
Stage:
[8] WRITE TO PARTITION [ lk ]

Download failed.
Disconnect!
User stopped.
------------------------------------------------------------------

What might be causing the download to fail? 
Any advice gladly appreciated.

Regards

mdm

Your USB detection looks strange. You said you did a read back. Which partition did you read back?
Tried this https://www.hovatek.com/forum/thread-40865.html ?

Note!
We have a reply schedule for Free Support. Please upgrade to Private Support if you can't wait.
Users browsing this thread:
 1 Guest(s)
Users browsing this thread:
 1 Guest(s)
YtWhTl
live chat
whatsapp telegram