Hovatek Forum DEVELOPMENT Android p80x root
Try our Online TWRP Builder..its free!
Can't login? Please, reset your password.


p80x root

p80x root

nasalspray
nasalspray
nasalspray
Enthusiastic Member
5
12-01-2023, 01:17 PM
#1



Hi Hovatek, thank you for all the information you have provided.

I've spent over 6hrs to work through each step of the rooting p80x guide and overcame each issue.

I successfully flashed a signed magisk recovery and vbmeta image.

I get the INFO LOCK FLAG IS UNLOCK!! but i don't mind that message.
The tablet boots into the OS fine but of course no root.

I am currently experiencing the same issue as  _Jaqb_
https://www.hovatek.com/forum/thread-326...#pid205402

You responded with using the research tool - but everything I'm reading and tried requires the p80x tablet to be in fastboot mode, which i am unable to get the tablet into recovery vol- + power as previous. I tried using research tool to shutdown the tablet while it is ON and OFF but the download button never triggers as describe in steps 15-17  How to power off a unisoc / spreadtrum device from fastboot mode (hovatek.com)

Any help to get the phone to boot into recovery would be much appreciated!
nasalspray
nasalspray
nasalspray
Enthusiastic Member
5
12-01-2023, 03:52 PM
#2
Device teclast p80x g5k5. 
Update - managed to connect the tablet to windows PC and use adb to reboot into bootloader which is fastboot. Tried reflashing vbmeta and recovery custom signed. Both successfully flashed.
Still unable to get into recover via hardware keeps or via adb reboot recovery command. It sits at the teclast logo screen.
I checked my firmware.pac and even though the zip says g5k5 research to says it's g5k6.

So I downloaded g5k4 pac file, extracted/patched/signed the recovery file and flashed it but no difference. Still can't get the table to boot into recovery.
nasalspray
nasalspray
nasalspray
Enthusiastic Member
5
15-01-2023, 12:59 PM
#3
OK finally achieved permanent root.
Just sharing my journey so others who are trying to root might save time.

I messed up plenty of times and bricked it numerous times but luckily I used the teclast upgrade tool to bring it back to life each time.

So this is the final steps that achieved permanent root via boot.img

1. Followed guide much more closely (forum/thread-32678.html)
2. Bootloader unlocking was straightforward and achieved success first time (3 days ago)
3. Creating the signed vbmeta-sign-custom.img was fine the first time as I was trying the recovery method
4. Flashing vbmeta-sign-custom.img and a signed magisk_patched-recovery.img was fine - but no matter what I did (over 10 times), I couldn't turn off the tablet via fastboot to avoid the patched recovery img being overwritten. I lost abilit to enter recovery and bootloader/fastboot via button press and had to use windows adb reboot bootloader.
5. So I tried the boot.img method. Bricked it 5 times.
5.1 I couldn't get a successful flash of the boot.img - tried about 20 times different ways to patch and sign.
5.2 Kept re-reading the posts in the thread until finally realised that i had to modify the avbtool command to to apply the hovatek.bin to the right partition. To save anyone else who might be trying this (I couldn't find the command anywhere on this site using search).

To create a vbmeta image for BOOT ONLY -
"boot:1:keys/hovatek.bin" and "recovery:2:keys/key_recovery.bin"

python2 avbtool make_vbmeta_image --key rsa4096_vbmeta.pem --algorithm SHA256_RSA4096 --flag 2 --chain_partition boot:1:keys/hovatek.bin --chain_partition system:3:keys/key_system.bin --chain_partition vendor:4:keys/key_vendor.bin --chain_partition product:10:keys/key_product.bin --chain_partition dtbo:9:keys/key_dtbo.bin --chain_partition recovery:2:keys/key_recovery.bin --chain_partition l_modem:5:keys/key_l_modem.bin --chain_partition l_ldsp:6:keys/key_l_ldsp.bin --chain_partition l_gdsp:7:keys/key_l_gdsp.bin --chain_partition pm_sys:8:keys/key_pm_sys.bin --chain_partition dtb:11:keys/key_dtb.bin --padding_size 16384 --output vbmeta-sign-custom-boot.img

The original command for RECOVERY was
"boot:1:keys/key_boot.bin" and "recovery:2:keys/hovatek.bin"

python2 avbtool make_vbmeta_image --key rsa4096_vbmeta.pem --algorithm SHA256_RSA4096 --flag 2 --chain_partition boot:1:keys/key_boot.bin --chain_partition system:3:keys/key_system.bin --chain_partition vendor:4:keys/key_vendor.bin --chain_partition product:10:keys/key_product.bin --chain_partition dtbo:9:keys/key_dtbo.bin --chain_partition recovery:2:keys/hovatek.bin --chain_partition l_modem:5:keys/key_l_modem.bin --chain_partition l_ldsp:6:keys/key_l_ldsp.bin --chain_partition l_gdsp:7:keys/key_l_gdsp.bin --chain_partition pm_sys:8:keys/key_pm_sys.bin --chain_partition dtb:11:keys/key_dtb.bin --padding_size 16384 --output vbmeta-sign-custom.img

5.3 Now I have a vbmeta-sign-custom-boot.img
6. Patching the stock boot.img - I messed this up a few times using various magisk versions and options - so each time I flashed it bricked the tablet.
The options THAT WORKED.
Use the latest Canary build from the magisk website. its called app_debug.apk 831a398b (25206) (34) (D)
MUST select Recovery (as per the youtube video on how to patch boot.img). DO NOT SELECT vbmeta boot image
In this version of magisk canary there is no option to preserve like the youtube video.
Once patched - rename it to magisk_patched-boot.img
7. Sign the patched boot image with the command

python2 avbtool add_hash_footer --image magisk_patched-boot.img --partition_name boot--partition_size 36700160 --key hovatek.pem --algorithm SHA256_RSA4096

7.1 Now you have a matching vbmeta custom boot image and the magisk patched signed boot image.
8. Boot to fastboot
8.1 On my p80x g5k5 - i flashed both stock g5k4 and g5k6 firmware.pac after bricking and both worked fine - I decided to use the newer one g5k6. There is no stock g5k5 from the teclast website (when you download g5k5 firmware.pac, researcher and upgrade tool reads it as g5k6).
Method to boot to fastboot. Shutdown tablet first. Press hold volume down and press hold power button same time and hold for around 10sec until the tablet comes alive and shows the Teclast boot logo, release power button and continue to hold volume down. After a few more seconds the screen will go blank and you will be presented with the stock recovery. Select boot to bootloader - this is fastboot.
8.2 You can also boot the tablet to Android 9 - connect usb to Windows PC and type adb reboot bootloader. This will also boot the tablet to fastboot. But this stopped working after I installed all the drivers to get upgrade tool to work.
9. Flash vbmeta custom boot image and the magisk patched signed boot image - I flashed one after the other without rebooting.
10. Type fastboot reboot, or just turn off and turn on the tablet - you could probably put a pin in reset - though i didnt try that.
11. It will boot into Android 9 and now you have permanent root - confirmed by root checker

Hope this helps anyone trying to root their Teclast p80x. My reason for rooting - not to install custom rom, none exists anyways?
I want to change the device ID/type so some apps (Yi Home) will think it's a phone instead of a tablet and runs normally instead of crashing.
Users browsing this thread:
 1 Guest(s)
Users browsing this thread:
 1 Guest(s)
YtWhTl
live chat
whatsapp telegram