Hovatek Forum MOBILE Android [Please help] Realme 8 5G Format + Download = no display
Try our Online TWRP Builder..its free!
Can't login? Please, reset your password.


[Please help] Realme 8 5G Format + Download = no display

[Please help] Realme 8 5G Format + Download = no display

Pages (3): 1 2 3 Next
ktmall4
ktmall4
ktmall4
Enthusiastic Member
11
29-09-2022, 07:36 AM
#1



Hi, just two weeks ago my phone firmware was updated but the battery and overall experience became worse so I decided to downgrade, to sum it up I:

  1. Flash older firmware using SP Flash Tool - IMEI lost and no sim detected.
  2. Tried a different region firmware but this time I left the format all option selected (big mistake) - After that my phone would never turn on again and only vibrate whenever I'd press the power button, also no fastboot nor recovery anymore.
  3. Tried flashing the old firmware that worked (had to use mtk client only to flash opporeserve2.img because otherwise SPFT would give me error) - It succeeded giving me the green check on SPFT but the phone would still not turn on.
  4. Disconnected and reconnected the battery and flashed (I had to disassembly the phone)- no success
  5. Left the battery to drain - after 5 days it would no longer turn on unless I connect it to the charger.
  6. Tried flashing the firmware again - The flashing was a success as usual, still black screen but this time I could hear the locking sound when pressing the power button twice

Somehow I activated Talkback - now the phone tells me if I press the power, volume up or volume down button. And when I plug the charger it tells me that the battery is 1% but wouldn't charge no matter how long I leave it. 


What else can I do ?

Thanks in advance.
justshez
justshez
justshez
Intern
1,801
01-10-2022, 08:01 PM
#2
(29-09-2022, 07:36 AM)ktmall4 Hi, just two weeks ago my phone firmware was updated but the battery and overall experience became worse so I decided to downgrade, to sum it up I:

  1. Flash older firmware using SP Flash Tool - IMEI lost and no sim detected.
  2. Tried a different region firmware but this time I left the format all option selected (big mistake) - After that my phone would never turn on again and only vibrate whenever I'd press the power button, also no fastboot nor recovery anymore.
  3. Tried flashing the old firmware that worked (had to use mtk client only to flash opporeserve2.img because otherwise SPFT would give me error) - It succeeded giving me the green check on SPFT but the phone would still not turn on.
  4. Disconnected and reconnected the battery and flashed (I had to disassembly the phone)- no success
  5. Left the battery to drain - after 5 days it would no longer turn on unless I connect it to the charger.
  6. Tried flashing the firmware again - The flashing was a success as usual, still black screen but this time I could hear the locking sound when pressing the power button twice

Somehow I activated Talkback - now the phone tells me if I press the power, volume up or volume down button. And when I plug the charger it tells me that the battery is 1% but wouldn't charge no matter how long I leave it. 


What else can I do ?

Thanks in advance.

You'll need a full firmware dump of the exact same device as yours to revive it.
Have you tried flashing the original firmware build?

Note!
We have a reply schedule for Free Support. Please upgrade to Private Support if you can't wait.
ktmall4
ktmall4
ktmall4
Enthusiastic Member
11
02-10-2022, 07:42 AM
#3
(01-10-2022, 08:01 PM)Abdulakeem14
(29-09-2022, 07:36 AM)ktmall4 Hi, just two weeks ago my phone firmware was updated but the battery and overall experience became worse so I decided to downgrade, to sum it up I:

  1. Flash older firmware using SP Flash Tool - IMEI lost and no sim detected.
  2. Tried a different region firmware but this time I left the format all option selected (big mistake) - After that my phone would never turn on again and only vibrate whenever I'd press the power button, also no fastboot nor recovery anymore.
  3. Tried flashing the old firmware that worked (had to use mtk client only to flash opporeserve2.img because otherwise SPFT would give me error) - It succeeded giving me the green check on SPFT but the phone would still not turn on.
  4. Disconnected and reconnected the battery and flashed (I had to disassembly the phone)- no success
  5. Left the battery to drain - after 5 days it would no longer turn on unless I connect it to the charger.
  6. Tried flashing the firmware again - The flashing was a success as usual, still black screen but this time I could hear the locking sound when pressing the power button twice

Somehow I activated Talkback - now the phone tells me if I press the power, volume up or volume down button. And when I plug the charger it tells me that the battery is 1% but wouldn't charge no matter how long I leave it. 


What else can I do ?

Thanks in advance.

You'll need a full firmware dump of the exact same device as yours to revive it.
Have you tried flashing the original firmware build?

So that means I would need someone with the russian version to dump their firmware? I have a backup made with twrp, but I'm not sure if I can flash that with mtk client since the files have .win extension.
By original firmware build you mean the firmware the phone came with ? Sadly I haven't found that exact version. What I have tried is flashing the first firmware the phone released with but no luck.
Androbaxton
Androbaxton
Androbaxton
Techie Member
58
02-10-2022, 09:56 AM
#4
Device is INFINIX SMART X5010
I did the same mistake about 6 months ago. 
can someone help me with
a full firmware dump of the exact same device as mine to revive it.
for is totally dead. can't boot up nor make any sounds. not even vibrate
hovatek
hovatek
hovatek
Administrator
49,618
03-10-2022, 12:24 PM
#5



(02-10-2022, 09:56 AM)Androbaxton Device is INFINIX SMART X5010
I did the same mistake about 6 months ago. 
can someone help me with
a full firmware dump of the exact same device as mine to revive it.
for is totally dead. can't boot up nor make any sounds. not even vibrate

Create a thread by clicking Ask Question at the top

Note!
We have a reply schedule for Free Support. Please upgrade to Private Support if you can't wait.
hovatek
hovatek
hovatek
Administrator
49,618
03-10-2022, 12:26 PM
#6
(29-09-2022, 07:36 AM)ktmall4 Hi, just two weeks ago my phone firmware was updated but the battery and overall experience became worse so I decided to downgrade, to sum it up I:

  1. Flash older firmware using SP Flash Tool - IMEI lost and no sim detected.
  2. Tried a different region firmware but this time I left the format all option selected (big mistake) - After that my phone would never turn on again and only vibrate whenever I'd press the power button, also no fastboot nor recovery anymore.
  3. Tried flashing the old firmware that worked (had to use mtk client only to flash opporeserve2.img because otherwise SPFT would give me error) - It succeeded giving me the green check on SPFT but the phone would still not turn on.
  4. Disconnected and reconnected the battery and flashed (I had to disassembly the phone)- no success
  5. Left the battery to drain - after 5 days it would no longer turn on unless I connect it to the charger.
  6. Tried flashing the firmware again - The flashing was a success as usual, still black screen but this time I could hear the locking sound when pressing the power button twice

Somehow I activated Talkback - now the phone tells me if I press the power, volume up or volume down button. And when I plug the charger it tells me that the battery is 1% but wouldn't charge no matter how long I leave it. 


What else can I do ?

Thanks in advance.

You need to flash the latest firmware for your original region

Note!
We have a reply schedule for Free Support. Please upgrade to Private Support if you can't wait.
ktmall4
ktmall4
ktmall4
Enthusiastic Member
11
06-10-2022, 07:50 AM
#7
(03-10-2022, 12:26 PM)hovatek
(29-09-2022, 07:36 AM)ktmall4 Hi, just two weeks ago my phone firmware was updated but the battery and overall experience became worse so I decided to downgrade, to sum it up I:

  1. Flash older firmware using SP Flash Tool - IMEI lost and no sim detected.
  2. Tried a different region firmware but this time I left the format all option selected (big mistake) - After that my phone would never turn on again and only vibrate whenever I'd press the power button, also no fastboot nor recovery anymore.
  3. Tried flashing the old firmware that worked (had to use mtk client only to flash opporeserve2.img because otherwise SPFT would give me error) - It succeeded giving me the green check on SPFT but the phone would still not turn on.
  4. Disconnected and reconnected the battery and flashed (I had to disassembly the phone)- no success
  5. Left the battery to drain - after 5 days it would no longer turn on unless I connect it to the charger.
  6. Tried flashing the firmware again - The flashing was a success as usual, still black screen but this time I could hear the locking sound when pressing the power button twice

Somehow I activated Talkback - now the phone tells me if I press the power, volume up or volume down button. And when I plug the charger it tells me that the battery is 1% but wouldn't charge no matter how long I leave it. 


What else can I do ?

Thanks in advance.

You need to flash the latest firmware for  your original region
That's what I've done, SP flash tool completes successfully but still no boot.
hovatek
hovatek
hovatek
Administrator
49,618
07-10-2022, 08:02 AM
#8
(06-10-2022, 07:50 AM)ktmall4 That's what I've done, SP flash tool completes successfully but still no boot.

What was the build number of the buggy firmware you originally updated to? Also what is your phone's original region?
This post was last modified: 07-10-2022, 08:03 AM by hovatek.

Note!
We have a reply schedule for Free Support. Please upgrade to Private Support if you can't wait.
ktmall4
ktmall4
ktmall4
Enthusiastic Member
11
08-10-2022, 06:30 AM
#9
(07-10-2022, 08:02 AM)hovatek What was the build number of the buggy firmware you originally updated to? Also what is your phone's original region?

RMX3241_11_C.03, the phone region is Russia, the box says RMX3241RU and it even came with some russian apps pre-installed.
hovatek
hovatek
hovatek
Administrator
49,618
10-10-2022, 04:59 AM
#10
(08-10-2022, 06:30 AM)ktmall4 RMX3241_11_C.03, the phone region is Russia, the box says RMX3241RU and it even came with some russian apps pre-installed.

Flash the latest Russian firmware following https://www.hovatek.com/blog/my-experien...-5g-china/
Lets see what happens

Note!
We have a reply schedule for Free Support. Please upgrade to Private Support if you can't wait.
Pages (3): 1 2 3 Next
Users browsing this thread:
 1 Guest(s)
Users browsing this thread:
 1 Guest(s)
YtWhTl