Hovatek Forum MOBILE Android Non-working network on Xiaomi Redmi 10 2022
Try our Online TWRP Builder..its free!
Can't login? Please, reset your password.


Non-working network on Xiaomi Redmi 10 2022

Non-working network on Xiaomi Redmi 10 2022

crathob
crathob
crathob
Newbie
4
09-09-2022, 03:07 PM
#1



Good day

There's a similar thread open that I dont want to hijack. I would appreciate suggestions to get the network side of the device working again. After some reading I think I messed up NVdata by using format all on spflash.

I have the:
  • Redmi 10 2022 (I believe it is selenes)
  • Model 22011119UY
  • Original firmware was 12.5.2.0 RKUZAVC (Note this is the South African market (ZA) with carrier locked to Vodacom.
  • Unlocked bootloader, stock recovery, able to access fastboot.
I flashed vbmeta, boot and recovery images to install custom firmware. Originally the device was bootlooping with no access to fastboot or recovery. I bypassed the secureboot and managed to flash selene V12.5.20.0.RKUMIXM (global) with SPFlash, after which I changed the blank IMEI numbers back to those on my box. I can now access fastboot and recovery. The device states (NV data corrupt) at the recovery page and wont boot into system.

After this I installed the China ROM for the selenes (V12.5.2.0.RKUCNXM). The phone boots into system fine, but doesnt detect any simcards or the IMEI numbers. ENG rom sees the IMEI numbers but has no signal.

Is the issue perhaps that you need the original firmware for it to function? Is there anything else i can try?

Thanks
crathob
crathob
crathob
Newbie
4
10-09-2022, 04:07 PM
#2
Good day

There's a similar thread open that I dont want to hijack. I would appreciate suggestions to get the network side of the device working again. After some reading I think I messed up NVdata by using format all on spflash.

I have the:
  • Redmi 10 2022 (I believe it is selenes)
  • Model 22011119UY
  • Original firmware was 12.5.2.0 RKUZAVC (Note this is the South African market (ZA) with carrier locked to Vodacom.
  • Unlocked bootloader, stock recovery, able to access fastboot.
I flashed vbmeta, boot and recovery images to install custom firmware. Originally the device was bootlooping with no access to fastboot or recovery. I bypassed the secureboot and managed to flash selene V12.5.20.0.RKUMIXM (global) with SPFlash, after which I changed the blank IMEI numbers back to those on my box. I can now access fastboot and recovery. The device states (NV data corrupt) at the recovery page and wont boot into system.

After this I installed the China ROM for the selenes (V12.5.2.0.RKUCNXM). The phone boots into system fine, but doesnt detect any simcards or the IMEI numbers. ENG rom sees the IMEI numbers but has no signal.

Is the issue perhaps that you need the original firmware for it to function?

Thanks
justshez
justshez
justshez
Intern
1,802
11-09-2022, 03:58 AM
#3
(09-09-2022, 03:07 PM)crathob Good day

There's a similar thread open that I dont want to hijack. I would appreciate suggestions to get the network side of the device working again. After some reading I think I messed up NVdata by using format all on spflash.

I have the:
  • Redmi 10 2022 (I believe it is selenes)
  • Model 22011119UY
  • Original firmware was 12.5.2.0 RKUZAVC (Note this is the South African market (ZA) with carrier locked to Vodacom.
  • Unlocked bootloader, stock recovery, able to access fastboot.
I flashed vbmeta, boot and recovery images to install custom firmware. Originally the device was bootlooping with no access to fastboot or recovery. I bypassed the secureboot and managed to flash selene V12.5.20.0.RKUMIXM (global) with SPFlash, after which I changed the blank IMEI numbers back to those on my box. I can now access fastboot and recovery. The device states (NV data corrupt) at the recovery page and wont boot into system.

After this I installed the China ROM for the selenes (V12.5.2.0.RKUCNXM). The phone boots into system fine, but doesnt detect any simcards or the IMEI numbers. ENG rom sees the IMEI numbers but has no signal.

Is the issue perhaps that you need the original firmware for it to function? Is there anything else i can try?

Thanks
Flashback the original firmware first

Note!
We have a reply schedule for Free Support. Please upgrade to Private Support if you can't wait.
crathob
crathob
crathob
Newbie
4
11-09-2022, 05:51 AM
#4
I dont have access to the original firmware and XFU doesn't have it, it looks like a specific firmware for this market
justshez
justshez
justshez
Intern
1,802
12-09-2022, 02:01 PM
#5



(11-09-2022, 03:58 AM)Abdulakeem14
(09-09-2022, 03:07 PM)crathob Good day

There's a similar thread open that I dont want to hijack. I would appreciate suggestions to get the network side of the device working again. After some reading I think I messed up NVdata by using format all on spflash.

I have the:
  • Redmi 10 2022 (I believe it is selenes)
  • Model 22011119UY
  • Original firmware was 12.5.2.0 RKUZAVC (Note this is the South African market (ZA) with carrier locked to Vodacom.
  • Unlocked bootloader, stock recovery, able to access fastboot.
I flashed vbmeta, boot and recovery images to install custom firmware. Originally the device was bootlooping with no access to fastboot or recovery. I bypassed the secureboot and managed to flash selene V12.5.20.0.RKUMIXM (global) with SPFlash, after which I changed the blank IMEI numbers back to those on my box. I can now access fastboot and recovery. The device states (NV data corrupt) at the recovery page and wont boot into system.

After this I installed the China ROM for the selenes (V12.5.2.0.RKUCNXM). The phone boots into system fine, but doesnt detect any simcards or the IMEI numbers. ENG rom sees the IMEI numbers but has no signal.

Is the issue perhaps that you need the original firmware for it to function? Is there anything else i can try?

Thanks
Flashback the original firmware first
You'll have to take a full firmware backup of the same device model as your phone and use it to restore yours

Note!
We have a reply schedule for Free Support. Please upgrade to Private Support if you can't wait.
maxpayne
maxpayne
maxpayne
Intern
3,602
13-09-2022, 06:51 PM
#6
(10-09-2022, 04:07 PM)crathob Good day

There's a similar thread open that I dont want to hijack. I would appreciate suggestions to get the network side of the device working again. After some reading I think I messed up NVdata by using format all on spflash.

I have the:
  • Redmi 10 2022 (I believe it is selenes)
  • Model 22011119UY
  • Original firmware was 12.5.2.0 RKUZAVC (Note this is the South African market (ZA) with carrier locked to Vodacom.
  • Unlocked bootloader, stock recovery, able to access fastboot.
I flashed vbmeta, boot and recovery images to install custom firmware. Originally the device was bootlooping with no access to fastboot or recovery. I bypassed the secureboot and managed to flash selene V12.5.20.0.RKUMIXM (global) with SPFlash, after which I changed the blank IMEI numbers back to those on my box. I can now access fastboot and recovery. The device states (NV data corrupt) at the recovery page and wont boot into system.

After this I installed the China ROM for the selenes (V12.5.2.0.RKUCNXM). The phone boots into system fine, but doesnt detect any simcards or the IMEI numbers. ENG rom sees the IMEI numbers but has no signal.

Is the issue perhaps that you need the original firmware for it to function?

Thanks

Are you able to get the firmware for your original region (before you cross-flashed?

Note!
We have a reply schedule for Free Support. Please upgrade to Private Support if you can't wait.
crathob
crathob
crathob
Newbie
4
13-09-2022, 06:56 PM
#7
(13-09-2022, 06:51 PM)maxpayne
(10-09-2022, 04:07 PM)crathob Good day

There's a similar thread open that I dont want to hijack. I would appreciate suggestions to get the network side of the device working again. After some reading I think I messed up NVdata by using format all on spflash.

I have the:
  • Redmi 10 2022 (I believe it is selenes)
  • Model 22011119UY
  • Original firmware was 12.5.2.0 RKUZAVC (Note this is the South African market (ZA) with carrier locked to Vodacom.
  • Unlocked bootloader, stock recovery, able to access fastboot.
I flashed vbmeta, boot and recovery images to install custom firmware. Originally the device was bootlooping with no access to fastboot or recovery. I bypassed the secureboot and managed to flash selene V12.5.20.0.RKUMIXM (global) with SPFlash, after which I changed the blank IMEI numbers back to those on my box. I can now access fastboot and recovery. The device states (NV data corrupt) at the recovery page and wont boot into system.

After this I installed the China ROM for the selenes (V12.5.2.0.RKUCNXM). The phone boots into system fine, but doesnt detect any simcards or the IMEI numbers. ENG rom sees the IMEI numbers but has no signal.

Is the issue perhaps that you need the original firmware for it to function?

Thanks

Are you able to get the firmware for your original region (before you cross-flashed?

No, what I have done is sent it in to that exact network provider for repairs. I asked for the the original firmware to be flashed. Its not available online... They should get back within this week.
16-12-2022, 03:06 PM
#8
Have you solved the issue?
Users browsing this thread:
 1 Guest(s)
Users browsing this thread:
 1 Guest(s)
YtWhTl