Hovatek Forum MOBILE Android [Please help] No 3g and 4g network after flashing Infinix x572 only edge
Try our Online TWRP Builder..its free!
Can't login? Please, reset your password.


[Please help] No 3g and 4g network after flashing Infinix x572 only edge

[Please help] No 3g and 4g network after flashing Infinix x572 only edge

domlex1
domlex1
domlex1
Junior Member
19
02-04-2018, 02:31 PM
#1



Good day, please I need some help with my android infinix x572 note 4 X572-H5312CE-N-170816V67, I was able to successfully flash it and root it after it got bricked. The issue now is that I don't have 3g or 4g network, only edge.
Actually after flashing, the imei was null, so I followed your posts to restore it with maui meta, but I'm only getting edge network now. Please how do I get back my 3g and 4g network. Thanks.
hovatek
hovatek
hovatek
Administrator
49,616
02-04-2018, 05:36 PM
#2
(02-04-2018, 02:31 PM)domlex1 Good day, please I need some help with my android infinix x572 note 4 X572-H5312CE-N-170816V67, I was able to successfully flash it and root it after it got bricked. The issue now is that I don't have 3g or 4g network, only edge.
Actually after flashing, the imei was null, so I followed your posts to restore it with maui meta, but I'm only getting edge network now. Please how do I get back my 3g and 4g network. Thanks.

refer to https://www.hovatek.com/blog/how-to-fix-...-only-mode
alt. you could try flashing nvram for x572 @ https://www.hovatek.com/forum/thread-19499-page-2.html
domlex1
domlex1
domlex1
Junior Member
19
03-04-2018, 08:58 AM
#3
Thank you, I have tried virtually everything there and it is still Edge network only, the only thing I have not tried is getting the nvram backup from another phone of the same model. Please is there any other known fix?
hovatek
hovatek
hovatek
Administrator
49,616
03-04-2018, 11:03 AM
#4
(03-04-2018, 08:58 AM)domlex1 Thank you, I have tried virtually everything there and it is still Edge network only, the only thing I have not tried is getting the nvram backup from another phone of the same model. Please is there any other known fix?

It still boils down to a Secro - NVRAM backup > restore

Note!
We have a reply schedule for Free Support. Please upgrade to Private Support if you can't wait.
Users browsing this thread:
 1 Guest(s)
Users browsing this thread:
 1 Guest(s)
YtWhTl