Hovatek Forum
TWRP encryption - Printable Version

+- Hovatek Forum (https://www.hovatek.com/forum)
+-- Forum: DEVELOPMENT (https://www.hovatek.com/forum/forum-38.html)
+--- Forum: Android (https://www.hovatek.com/forum/forum-39.html)
+--- Thread: TWRP encryption (/thread-29994.html)

Pages: 1 2 3


TWRP encryption - ali21 - 14-09-2019

Ported TWRP Recovery using Auto Porter V1.5 for my TECNO KC1 (Android 9)
After booting into TWRP, it asks for decryption password, internal storage shows 0 MB and goes back to stock recovery after booting to system. Appreciate any help


RE: TWRP encryption - X3non - 14-09-2019

(14-09-2019, 06:55 AM)ali21 Wrote:  Ported TWRP Recovery using Auto Porter V1.5 for my TECNO KC1 (Android 9)
After booting into TWRP, it asks for decryption password, internal storage shows 0 MB and goes back to stock recovery after booting to system. Appreciate any help

for decryption, either try flashing no-verity-opt.zip then magisk.zip (copy both to extsd and flash from there) OR you can try the decryption method as explained @ https://www.hovatek.com/forum/thread-29013.html

for reverting back to stock recovery, try case 2 @ https://www.hovatek.com/forum/thread-10992.html OR try the method as described @ https://www.hovatek.com/forum/thread-29879-post-177478.html#pid177478


RE: TWRP encryption - ali21 - 15-09-2019

(14-09-2019, 10:41 AM)X3non Wrote:  for decryption, either try flashing no-verity-opt.zip then magisk.zip (copy both to extsd and flash from there) OR you can try the decryption method as explained @ https://www.hovatek.com/forum/thread-29013.html
After flashing patched boot image, checked status in Magisk Manager app but MAGISK and Root wasn't installed


RE: TWRP encryption - hovatek - 15-09-2019

(15-09-2019, 03:10 AM)ali21 Wrote:  After flashing patched boot image, checked status in Magisk Manager app but MAGISK and Root wasn't installed

Have you fixed the 0MB / encryption issue in TWRP?


RE: TWRP encryption - ali21 - 15-09-2019

(15-09-2019, 09:11 AM)hovatek Wrote:  Have you fixed the 0MB / encryption issue in TWRP?
Flashing no-verity-opt.zip returned error, so flashing Magisk.zip doesn't work. TWRP log:
- Error: Unknown ramdisk compression format ()!- Aborting...
Failed to patch boot image!Updater process ended with ERROR: 1
Error installing zip file '/external_sd/no-verity-opt-encrypt-6.1.zip

Tried the decryption method explained in thread but Root wasn't installed even after successfully flashing patched boot image from Magisk Manager. So still stuck with encryption and 0 MB


RE: TWRP encryption - X3non - 16-09-2019

(15-09-2019, 10:08 AM)ali21 Wrote:  ...
Tried the decryption method explained in thread but Root wasn't installed even after successfully flashing patched boot image from Magisk Manager. So still stuck with encryption and 0 MB

TWRP > mount
can you mount vendor partition while in TWRP?


RE: TWRP encryption - ali21 - 16-09-2019

(16-09-2019, 09:41 AM)X3non Wrote:  TWRP > mount
can you mount vendor partition while in TWRP?
Yeah, I can mount Vendor Partition


RE: TWRP encryption - X3non - 17-09-2019

(16-09-2019, 11:26 AM)ali21 Wrote:  Yeah, I can mount Vendor Partition

ok, try this below
mount vendor then goto advanced > file manager > navigate to \vendor
then complete step 3 - 5 of the header "DECRYPTING ‘/data’ PARTITION" @ https://www.hovatek.com/forum/thread-29013.html

since you won't be able to edit fstab in twrp, copy it to internal_sd or ext_sd then copy it to your PC and edit using a txt editor e.g notepad++ (if twrp has functional mtp then you can copy to and from without needing to reboot the phone to homescreen)

once you've edited the necessary file(s), copy them from the PC back to the phone & copy them to their respective location using file manager in TWRP

once done, FORMAT /data in twrp (this is different from wipe data, ensure you choose the format option & this will wipe everything from your device so be sure to backup your files first)

finally reboot twrp and check if encryption is gone


RE: TWRP encryption - hovatek - 17-09-2019

(15-09-2019, 10:08 AM)ali21 Wrote:  Flashing no-verity-opt.zip returned error, so flashing Magisk.zip doesn't work. TWRP log:
- Error: Unknown ramdisk compression format ()!- Aborting...
Failed to patch boot image!Updater process ended with ERROR: 1
Error installing zip file '/external_sd/no-verity-opt-encrypt-6.1.zip

Tried the decryption method explained in thread but Root wasn't installed even after successfully flashing patched boot image from Magisk Manager. So still stuck with encryption and 0 MB

Magisk doesn't seem to support your boot image type. You're not alone on this.
A way to gain temporary root is:
1. Patch stock recovery.img using magisk manager
2. Flash the patched recovery via fastboot using fastboot flash recovery recovery.img
3. After flashing the recovery, hold the vol up + power button till the phone goes off. Release both once you see the boot logo
4. The phone will boot up normally. Check for root access
There's however a likelihood your phone won't detect SIM. Rebooting fixes that but then you lose root


RE: TWRP encryption - ali21 - 18-09-2019

(17-09-2019, 09:36 AM)X3non Wrote:  ok, try this below
mount vendor then goto advanced > file manager > navigate to \vendor
then complete step 3 - 5 of the header "DECRYPTING ‘/data’ PARTITION" @ https://www.hovatek.com/forum/thread-29013.html

since you won't be able to edit fstab in twrp, copy it to internal_sd or ext_sd then copy it to your PC and edit using a txt editor e.g notepad++ (if twrp has functional mtp then you can copy to and from without needing to reboot the phone to homescreen)

once you've edited the necessary file(s), copy them from the PC back to the phone & copy them to their respective location using file manager in TWRP

once done, FORMAT /data in twrp (this is different from wipe data, ensure you choose the format option & this will wipe everything from your device so be sure to backup your files first)

finally reboot twrp and check if encryption is gone
*For the following step # 3 in guide:
3. Open Vendor > nvdata > fstab.mt6763
There is no folder named NVDATA, but there is a FILE named NVDATA in \vendor which I can't copy to external sd card.
*The fstab file is present in \vendor\etc which can be edited.
*Formatting \data doesn't work while it's encrypted