Hovatek Forum

Full Version: MT8167S - SP Dump
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi,

Having trouble dumping a chinese smart clock that's running MT8167S.

MT8167 payload for mtk-bypass runs and is correct (dumped brom and checked function offsets and sec table).
Code:
[2021-06-28 00:07:40.653474] Waiting for device
[2021-06-28 00:07:49.098563] Found port = COM6
[2021-06-28 00:07:49.364155] Device hw code: 0x8167
[2021-06-28 00:07:49.379774] Device hw sub code: 0x8a00
[2021-06-28 00:07:49.379774] Device hw version: 0xcb00
[2021-06-28 00:07:49.379774] Device sw version: 0x1
[2021-06-28 00:07:49.395429] Device secure boot: True
[2021-06-28 00:07:49.395429] Device serial link authorization: False
[2021-06-28 00:07:49.411023] Device download agent authorization: True
[2021-06-28 00:07:49.426646] Disabling watchdog timer
[2021-06-28 00:07:49.457912] Disabling protection
[2021-06-28 00:07:52.995171] Protection disabled

I have the factory image for it (which works, flashed whole image to be 100% sure)
Extracted preloader from boot0.img factory image and created scatter file (both by hand and by wwr)

But still when trying to read back I get:
STATUS_PRELOADER_INVALID (0xC0030004)

I'm new to the MTK world and have been out of the android world in general for some years so need some pointers I'm afraid!
(02-07-2021, 12:55 AM)Whiterat Wrote: [ -> ]...But still when trying to read back I get:
STATUS_PRELOADER_INVALID (0xC0030004) ...

For this error, when you load the scatter file in download tab, ensure to include preloader file and tick the checkbox beside preloader then you can return back to readback tab
Refer to https://www.hovatek.com/forum/thread-439.html
Thanks for the reply.

Unfortunately already tried this... I searched all the topics on this site in particular for this error and to see what resolutions people found.
(02-07-2021, 03:47 PM)Whiterat Wrote: [ -> ]Thanks for the reply.

Unfortunately already tried this... I searched all the topics on this site in particular for this error and to see what resolutions people found.

are you saying that the fix didn't work for you? post screenshots showing download tab in your sp flash tool before trying readback
Tried a 3rd PC and it works with everything I had - same drivers, spft, scatter and preloader.

Is it usual that SPFT is so finicky?

Just feels like one of those things that should work - or not, not just obscure errors.
(02-07-2021, 09:49 PM)Whiterat Wrote: [ -> ]Tried a 3rd PC and it works with everything I had - same drivers, spft, scatter and preloader.

Is it usual that SPFT is so finicky? ...

sometime it happens